Oracle R12: Patch 21696441: Unable to validate some of the invoices (upgraded & new

We recently had an email from a client about Patch 21696441 and this is what they said;

“Top tip for you – do not install “Patch 21696441: Unable to validate some of the invoices (upgraded & new)”.  It completely messes up the database, and various tax tables will not compile.  We installed this as part of some AGIS trouble shooting.”

So install with caution and throughly test.